Websites slow to respond
Incident Report for Next Level Technology
Postmortem

We have identified the issue and have worked with our upstream vendors to help mitigate bot traffic attacking our network. We expect site performance issues while we tweak rules over the next week or so.

Posted Feb 10, 2022 - 15:33 CST

Resolved
We are seeing a handful of clients websites impacted by slowdowns. Currently investigating the issue.
Posted Feb 07, 2022 - 06:00 CST